New jv16 PowerTools Updated - Build 1292 Released

Discussion relating to the current version of jv16 PowerTools.
jv16
Developer
Posts: 6514
Joined: Sun Mar 13, 2005 7:57 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by jv16 »

ledge1962 wrote: Sat Nov 06, 2021 3:36 am Further to the above, I deleted the 'X:...' file from the ignore list and reran the scan. This time it did display ALL of the files for review.

Unfortunately, it also displayed the Mosaic file (it is in the ignore list still) for deletion too.
Have you tried to add only the filename of this file to the Ignore List?
ledge1962 wrote: Sat Nov 06, 2021 3:36 am After the clean, it restarted my laptop WITHOUT my approval. This is not the first time it has done this.
What probably happens is that the cleaning happens so fast, you don't have time to see the "restart computer" checkbox, that is pre-checked on the screen. I have now fixed this issue by adding option to disable the automatic restarting of the computer. This is included in the Settings, starting with the next released version.

Thank you for your feedback!
jv16
Developer
Posts: 6514
Joined: Sun Mar 13, 2005 7:57 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by jv16 »

redseujac wrote: Sun Nov 07, 2021 1:22 pm Initial Setup reoccurring
It happens frequently Initial Setup reoccurs when starting the program apparently without any reason.

Also this morning when I started jv16 PT Initial Setup started also. When finished, I closed the program and started jv16 PT once more and Initial Setup started also again. Luckily it didn't start when I started jv16 PT next times.
Have you done any changes to the computer during this time? The Initial Setup needs to be run after there has been changes to the system, such as installation or uninstallation of software.
jv16
Developer
Posts: 6514
Joined: Sun Mar 13, 2005 7:57 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by jv16 »

Olyfant22 wrote: Sun Nov 07, 2021 9:23 pm Hi y'all :wink:

WHAT is this? :shock: And WHY? :roll:

It takes between 10-20 seconds before System Cleaner kicks in...!
Regrettably, I find it pretty annoying.
It takes time for all the scan modules to be created and initialized. Before you would see the generic scan progress view, now you see a graphic. There is no change in any functionality in this regard, only a bit nicer thing to look at.
ledge1962
New user
Posts: 28
Joined: Sat Feb 06, 2021 10:23 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by ledge1962 »

jv16 wrote: Mon Nov 08, 2021 8:50 am
ledge1962 wrote: Sat Nov 06, 2021 3:36 am Further to the above, I deleted the 'X:...' file from the ignore list and reran the scan. This time it did display ALL of the files for review.

Unfortunately, it also displayed the Mosaic file (it is in the ignore list still) for deletion too.
Have you tried to add only the filename of this file to the Ignore List?
ledge1962 wrote: Sat Nov 06, 2021 3:36 am After the clean, it restarted my laptop WITHOUT my approval. This is not the first time it has done this.
What probably happens is that the cleaning happens so fast, you don't have time to see the "restart computer" checkbox, that is pre-checked on the screen. I have now fixed this issue by adding option to disable the automatic restarting of the computer. This is included in the Settings, starting with the next released version.

Thank you for your feedback!
I added both the file and the Folder as separate entries. All this does is stop the log files from displaying, then deletes them if I run the Clean.
Do you know why the files starting with X: are occurring? They are obviously linked to the count error and only occur when I add a file to the ignore list from the 'review results' window? The file 'x:77aUHesV9vc66abq' appeared after I added the Log file ;
Log files | C:\Users\Ledge\AppData\Local\ | C:\Users\Ledge\AppData\Local\Fantasy_mosaics_48\Fmboxes_48.log
x:77aUHesV9vc66abq

This went from displaying 400+ to 37 out of 37 with NO log files displayed again. When I deleted the X: file out, and reran the clean, all were displayed again, including the file I told it to ignore.
I tried renaming the "Log files | C:.... to just c:.... (deleted the preceeding "Log files | "), but it still displayed the Mosaic file for deletion.
How do you want me to proceed, as this occurs on both my PC and Laptop??
jv16
Developer
Posts: 6514
Joined: Sun Mar 13, 2005 7:57 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by jv16 »

ledge1962 wrote: Mon Nov 08, 2021 10:25 pm I added both the file and the Folder as separate entries. All this does is stop the log files from displaying, then deletes them if I run the Clean.
Do you know why the files starting with X: are occurring? They are obviously linked to the count error and only occur when I add a file to the ignore list from the 'review results' window? The file 'x:77aUHesV9vc66abq' appeared after I added the Log file ;
Log files | C:\Users\Ledge\AppData\Local\ | C:\Users\Ledge\AppData\Local\Fantasy_mosaics_48\Fmboxes_48.log
x:77aUHesV9vc66abq

This went from displaying 400+ to 37 out of 37 with NO log files displayed again. When I deleted the X: file out, and reran the clean, all were displayed again, including the file I told it to ignore.
I tried renaming the "Log files | C:.... to just c:.... (deleted the preceeding "Log files | "), but it still displayed the Mosaic file for deletion.
How do you want me to proceed, as this occurs on both my PC and Laptop??
We are currently investigating this issue. No need for you to do anything right now. If we can reproduce the issue, we will fix it for the next version. I will keep you posted. Thank you again for your feedback on this matter!
siliconman01
Expert user
Posts: 1151
Joined: Mon Mar 14, 2005 1:55 pm
Location: West Virginia USA

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by siliconman01 »

On Windows 11x64 Pro, the Dashboard does not show program executable icons.
Attachments
Windows11icons.png
Windows11icons.png (120.94 KiB) Viewed 181 times
Debug.zip
(426.35 KiB) Downloaded 5 times
Platinum VIP License. A clean machine is a screaming machine! Windows 10x64 Pro on Home-built ASUS ROG Maximus VIII Extreme; Windows 11x64 Pro on Dell XPS 15 9575 2in1 laptop/tablet
jv16
Developer
Posts: 6514
Joined: Sun Mar 13, 2005 7:57 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by jv16 »

Griffy wrote: Fri Nov 05, 2021 10:34 pm
jv16 wrote: Thu Nov 04, 2021 7:45 am Can you give me an example of a temporary file that or files that are not detected?
Heh, all kinds of odd left-over files. I will let it build up again, scan it, and see whats left.

jv16 wrote: Thu Nov 04, 2021 7:45 am Can you give an example of such empty directory that is detected but not cleaned?
C:\Program Files\Java

Its empty, has been for a long time (I use AdoptOpenJDK/JRE now, which is in another dir).
I was able to reproduce and fix this problem, the fix will be included in the next released version (ETA: This month). Thank you very much for reporting!
razorflash
New user
Posts: 9
Joined: Sat Jun 21, 2014 2:06 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by razorflash »

Uninstaller runs forever. I have installed jv16 Power tools on my 3 pc:s. On 2 PC:s uninstaller runs fine ending up with result list, but on one PC it runs foever whereas the counter shows 12 % and doesn't advance at all. However the module list is updated continuosly.
What's going on? I suspect there is some bug in the software, as it has been for the last 2-3 years. Siic....
I have made a refresh of the Win 10 Pro OS via Creation Media Tool, made chkdsk with parameters chkdsk c: /v /f /b /r /x, sfc /scannow
operations to secure that I have a healthy machine, which I am convinced I have. I am a old PC professional since McIntoch and IBM PC Jubior days. Advice needed!
jv16
Developer
Posts: 6514
Joined: Sun Mar 13, 2005 7:57 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by jv16 »

razorflash wrote: Fri Nov 26, 2021 11:18 pm Uninstaller runs forever. I have installed jv16 Power tools on my 3 pc:s. On 2 PC:s uninstaller runs fine ending up with result list, but on one PC it runs foever whereas the counter shows 12 % and doesn't advance at all. However the module list is updated continuosly.
What's going on? I suspect there is some bug in the software, as it has been for the last 2-3 years. Siic....
I have made a refresh of the Win 10 Pro OS via Creation Media Tool, made chkdsk with parameters chkdsk c: /v /f /b /r /x, sfc /scannow
operations to secure that I have a healthy machine, which I am convinced I have. I am a old PC professional since McIntoch and IBM PC Jubior days. Advice needed!
What program are you trying to uninstall whose uninstallation seems to run forever with jv16 PowerTools? If I can reproduce the problem, I can fix it.
razorflash
New user
Posts: 9
Joined: Sat Jun 21, 2014 2:06 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by razorflash »

Hi. I now let the uninstaller run "forever". It took about 16 hours to finish. I only cleaned unfinished items. All switches to detect items were turmed on.
After rebbot I could regonize some effects of non-working softweres(they were uninstalled/reset of parameters to native), whereas it was easy to reactivete them.
Conclusion: The uninstaller engine is in my opion extremle slow. I think this is a design issue as my other laptops/pc:s the response were much quicker.
All mechines has the same level of OS. Win10 Pro version 21H2, OS-version 19044.1387. The main difference of the desktop layout is that the slow uninstaller machine has heavily setup of the desktop with numerous maps and underlying subdirectorys with many desktop shortcuts. I don't know if this circumstance can have an impact of the uninstallers slow respons.
razorflash
New user
Posts: 9
Joined: Sat Jun 21, 2014 2:06 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by razorflash »

The slow response of the uninstaller function can also depends on a poorly designed buffer-handling in the step/steps of the unimstaller procedure to detect components for cleaning.
jv16
Developer
Posts: 6514
Joined: Sun Mar 13, 2005 7:57 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by jv16 »

razorflash wrote: Sun Nov 28, 2021 3:04 pm Hi. I now let the uninstaller run "forever". It took about 16 hours to finish. I only cleaned unfinished items. All switches to detect items were turmed on.
After rebbot I could regonize some effects of non-working softweres(they were uninstalled/reset of parameters to native), whereas it was easy to reactivete them.
Conclusion: The uninstaller engine is in my opion extremle slow. I think this is a design issue as my other laptops/pc:s the response were much quicker.
All mechines has the same level of OS. Win10 Pro version 21H2, OS-version 19044.1387. The main difference of the desktop layout is that the slow uninstaller machine has heavily setup of the desktop with numerous maps and underlying subdirectorys with many desktop shortcuts. I don't know if this circumstance can have an impact of the uninstallers slow respons.
Can you please name which software you uninstalled with the Software Uninstaller? If you tell me the names of the software you uninstalled and I can reproduce the slowness issue, I can fix it. Edit: Or are you reporting that the Software Uninstaller is taking 16 hours to open, that is, to display the list of installed software? :shock:
razorflash
New user
Posts: 9
Joined: Sat Jun 21, 2014 2:06 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by razorflash »

Dear Sir. The uninstaller is at releaselevel jv16Power Tools ver 7.1.0.1292. I will return with software luninstaller result list tomorrow as the runinstaller will run about 16 hours. I have also reinstalled the jv16 Power Tools.
redseujac
Super Guru
Posts: 2977
Joined: Fri Mar 18, 2005 5:27 pm
Location: Belgium

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by redseujac »

Maybe he's not referring to Uninstaller but to the System Cleaner tool?
AMD Ryzen 7 1800X - Samsung 970 Pro NVMe M.2 512 GB - 16 GB RAM - NVIDIA GeForce RTX 1080 - Windows 10 Pro (x64) v21H1 - jv16 PT Platinum VIP - Dutch translator jv16 PT - Forum moderator
razorflash
New user
Posts: 9
Joined: Sat Jun 21, 2014 2:06 pm

Re: New jv16 PowerTools Updated - Build 1292 Released

Post by razorflash »

Noop. The slow object is "Software Uninstaller" not "System Cleaner".
Post Reply